Section Editor Plugin: First Stable Release

Section Editor is a plugin contains set of tools for working with long and lengthy tiddlers. It includes tools for

  • Sectionizer based on the wikitext heading (e.g. !, !!,…)
  • Section editing using simple editor or codeMirror editor
    • keyboard shortcuts are supported
  • Section folding (collapse/expand sections)

Code and demo

Acknowledgement

Reference:


Screencasts

This is update 0.2.8

  • Choose different section style

Styles

  • Set number of levels for sectionizing

set number of levels

  • Choose the editor

editor

6 Likes

Screencasts

Basic use

391_%pn

Use CodeMirror for editing sections

393_%pn

1 Like

The screencast looks great! :grinning_face_with_smiling_eyes: But things are weird and wonky on my end. I opened the demo page.

  • when I press the edit button, the other sections are removed except for the section I’m trying to edit. it doesn’t enter edit mode.
  • the other sections vanish in the source text too!

Folding works, though. I’m not sure if this is confined to my end or not.

Edit: I tried to record my screen too.

ezgif-3-d8c6d5fdb140

No it is not your end. I see the same.

If I open the demo with FF and Windows 10 it doesn’t allow me to edit anything. I did not change anything.

I do find the + x button for expanding / fold very confusing. I do expect an x button to remove something so that it’s gone. I think we do have icons for folding and opening in the core.

@sull-vitsy @Birthe
Would you please test it with Shiraz plugin and let me know if you still have the problem!

@pmario - I will check the FF. I will also add several styles to be able to choose your favorite one!

It is the same, still not editing with Shiraz and Section Editor at tiddlywik.com.
I am using Firefox on Linux.

Very interesting work, you are doing. :hugs:

It is the same with me as well. :cry: I tried Firefox and Safari on my Mac. Perhaps someone with Chrome should try too? What browser are you using @Mohammad?

@Birthe, @sull-vitsy

I have tested SE with Chrome/Edge!
So, maybe the details closure has problem with FireFox.
Let me to check in FF and return to you!

I would appreciate feedback, if anybody has checked Section Editor on Chrome/Edge!

Same issue on Chrome.

Have you tested your own demo from its URL in an incognito window (Ctrl+Shift+N)?

@saqimtiaz - seems there is smoothing wrong!
I will update the repo shortly!

A new update 0.2.5 pushed to GitHub!
The issue has been solved!

Please let me know your feedback!

1 Like

You nailed it. I just wrote my very first long tiddler. I know it will be the first of many.

1 Like

Update 0.2.6

  • Minor bug fixed!
  • Quick tutorial was added
  • autohide for edit button was activated

Code and Demo

Very nice, @Mohammad! Just had a quick try.

I made a new tiddler containing only headings, planning to fill in content using your interface. That resulted in a section heading as the last tiddler line. I didn’t think to put a linebreak after, and so the heading didn’t get an edit button.

It’s a small quirk, but if you mention it in your quick-start documentation, newcomers won’t get stuck.

A suggestion for flow: double-click to edit sections!

This is a nice UI alternative for those who want to keep their document in one piece.

Best,
Chris

TWC used to have that, I think. If it was removed, it was probably for a good reason.

Just sayin’

Hi Chris,
many thanks for you feedback!

Sure, I will also have look if I can have a workaround!

Good idea! I will add this to todos!

1 Like

I do love Shiraz, but if Section Editor depend on Shiraz also being installed, it should be mentioned.
The buttons are rather off and a very big space between headings and the editable section, if Shiraz is not installed.

The default behavior for double-click on text is to select the word under the cursor. If you use double-click to start editing, you won’t be able to select text in the standard way. Note: similarly, triple-click is used to select the current line of text.

Perhaps you could use a modifier key (i.e., “ctrl-click” to edit)