Upgrading Bob.exe and Bob Node installs to 5.2.0?

Folks,

## Upgrading TiddlyWiki on Node.js

I understand this works for all existing node installs (but Bob?)

Says to run

npm update -g tiddlywiki

On Mac or Linux you’ll need to add sudo like this:

sudo npm update -g tiddlywiki

Does anyone know if this is possible on already installed Bob.exe and Bob Node installs or do we need to wait for Jed to upgrade Bob?

When asked, Jed has always answered that we needed to download the Bob.exe.
We will have to wait, until it has been upgraded.

2 Likes

I’m sure this is a totally stupid question, but given that installing plugins is usually drag and drop, is there some really hacky way of upgrading BOB.exe to 5.2.0 by copy/pasting in the “Core” plugin or something? I tried just dragging and dropping the “core plugin” into my wiki and it didn’t do anything. It’s unclear if BOB.exe should now be considered abandoned or not as @inmysocks is away.

There are instructions for a manual install. They’re not too bad if you already have node:

git clone --depth=1 --branch v5.1.22 https://github.com/Jermolene/TiddlyWiki5.git
git clone --depth=1 https://github.com/OokTech/TW5-Bob.git TiddlyWiki5/plugins/OokTech/Bob
mkdir TiddlyWiki5/Wikis
cp -r TiddlyWiki5/plugins/OokTech/Bob/MultiUserWiki TiddlyWiki5/Wikis/BobWiki/

After that is finished, and to start up tiddlywiki later type:

cd TiddlyWiki5
node ./tiddlywiki.js Wikis/BobWiki  --wsserver

I changed 5.1.22 to 5.2.0. I had to add symlinks to titlecase versions of editions, plugins, and themes. I imagine you wouldn’t need to do that on Windows.

It seems to run, and I was able to create wikis that say “5.2.0”. Unfortunately, as I have found in the past, Bob wouldn’t acknowledge my existing node TW files. It was happy as long as it was using it’s own local wiki directory. Since I don’t use Bob, except for testing, I don’t know if anything else is broken.

I appreciate your reply @Mark_S - unfortunately this is a work need and I don’t have admin authority to any machine that would run on that network. BOB.exe is a no-install affair, so that’s what I’m stuck with for work. The new 5.2.0 features are so dang handy it’s hard to do without! Thanks again anyways.

It’s possible that you could extract node.exe from a download or find a portable version. Then put it in your Bob launch directory. You used to be able to run tiddlyserver that way, so it wouldn’t surprise me if you could run Bob that way too.

Thanks @Mark_S I did find a portable git for windows download here recently and started trying that. Unfortunately the error message on the git clone step leads me to believe I also have to worry about not being able to write to some places on the hard drive or something, so I’m going to try something external. If I figure it out, I’ll circle back here.

C:\Users\stobot\TiddlyWiki>git clone --depth=1 --branch v5.2.0 https://github.com/jermolene/tiddlywiki5.git
Cloning into 'tiddlywiki5'...
fatal: unable to access 'https://github.com/jermolene/tiddlywiki5.git/': SSL certificate problem: unable to get local issuer certificate

Can you run the git steps from a private machine with git installed, then zip it up and send it to yourself? Since you’re not using git again after the initial installs, you may not need it.

For that matter, you might be able to download the TW release as a zip, unzip it. Then unzip Bob inside of that. Then do the move steps. That’s basically what the git is doing – downloading the two repositories on top of each other.

Good idea, I’ll try that too. Thanks

@Mark_S Happy to say that I got it all working - thanks for your suggestions!

On personal computer:

  1. Downloaded portable Git for Windows: https://git-scm.com/download/win
    a. “Installed”/extracted it to a USB stick
  2. Followed the Bob Plugin instructions: https://github.com/OokTech/TW5-Bob
    a. Had to use git-bash.exe
    b. Installed TiddlyWiki5
    c. Installed Bob Plugin

On work computer:

  1. Copied the files from the USB drive to HDD
  2. Opened git-bash.exe and started the server from there

I’m sure this all seems obvious, but it’s a little foreign to a native Windows guy, so thought it might be useful to post here. I now have a 5.2.0 Bob running for my team. Thanks!

1 Like

I am a bit surprised it worked. I have been very slowly updating Bob and there is a lot to test. I haven’t abandoned it but I can’t put nearly as much time into it as I was before.

1 Like