TiddlyDesktop v0.0.18 - Error After Install - Apple Silicon

After installing the Apple silicon version of TiddlyDesktop (v0.0.18) on my M2 Max machine (Ventura 13.5), I receive the following error when starting the app: TiddlyDesktop.app is damaged and can’t be opened. You should move it to the Trash. I have tried deleting, re-downloading, and reinstalling. Wondering if I’m doing something wrong on my end or if there’s some other issue?

I suppose its possible it needs to be recompiled for the new platform ? Just like we have 32bit and 64bit windows and linux binaries. But I am not sure.

Hmm… I have an M1 mini running 13.5. I just installed v0.0.18, did the little security dance described on the download page and it opens just fine for me. Have you tried the old standards of rebooting or redownloading? You might also try booting into safe mode or running Onyx.

Googling the message, I see that maybe your file has been quarantined. Checkout this article:


Up and running! Thanks, folks. Appreciate all the speedy replies. Turns out Mark_S was on the right track: macOS quarantined TiddlyDesktop. This was fixed by running the following command in Terminal:

xattr -d com.apple.quarantine /path/to/TiddlyDesktop.app

Thanks again for your help.

1 Like