What namespace should be used for this plugin?
As a result of having started out as an intended core plugin, the FileUploads plugin uses the namespace
However, with the decision to keep this plugin outside the core repository for greater flexibility with release schedules and backwards compatibility concerns, this name space is no longer appropriate. Neither is the
$:/plugins/sq namespace that I use for my plugins as this is a community supported plugin via OpenCollective.
There has been a suggestion from Jeremy to introduce a new namespace such as
$:/plugins/collective for this category of semi-core plugins.
(I am also a bit unsure if this post is better suited to the Developers category, please feel free to move it if it is.)