Error 404 when saving to github

I’m finally getting around to setting up a github saver for my tiddlywiki what I’ve been using for months. I uploaded the 48.9 MB file to a new repository using terminal on my macbook pro. (Could the large file size be a problem? If so, how should I proceed?) I went through the other steps in the standard tutorials to set up a github page for my tiddlywiki. Going to now does bring up my tiddlywiki.

My problem is saving. This is what I entered in for the github saver tab. The PAT has access to admin:repo_hook, gist, repo, workflow, and write:packages.

I’ve deleted and retyped by hand each of these values several times.

The repository is here in case this helps: GitHub - noa-no-h/ideas: Noa's Idea Journal

Could the problem be with the dashes in my username? If so, what could break if I change my username?

Thank you for any help you can give me!


Be sure to type in the path even though it looks like it’s already filled-in (it could be a phantom path, which at least was a problem with earlier versions of Github saver).

I would suggest turning off auto-save. If you attempt to save too fast (e.g. by closing two or 3 edited tiddlers one after the other) you’ll get the 404 message. I imagine this is even more true when you have such a large file. GH doesn’t like these rapid-fire commits.

Good luck!

1 Like

Thanks so much!
Unfortunately, those don’t seem to be the problem. I turned off autosave and typed in the path again. What else would you try?

1 Like

As of Oct 1, 2020, GitHub uses “main” instead of “master”:

See article here:


1 Like

Yeah, but it should still work with “master” if that’s how the repository is set up. The last time I checked, mine still worked.

Yes. I’ve tried now with both master and main to no avail.

I would try it with a smaller file, in case it’s an issue of it timing out.

Yep. That saved! You must be right about the timing out thing!
Hmm. There have to be some people who have bigger TWs than I do and still use github saver, right? How do they do it without timing out?

(Thanks so much, by the way, for all the quick, thoughtful replies!)

Oh! Something to check. After you get the 404 message, go to gh and check – it might have saved but timed out sending you the confirmation.

I don’t know. It’s entirely possibly you are forging new ground here. Super large TW’s are already somewhat rare. My largest on GH is about 10M.

With the time of day and time of year you’re posting, it might take a bit before people get back to you with their experiences.

If you don’t actually need a repository you could try tiddlyhost. Or maybe gitlab (disclaimer – I’ve never used gl) will have faster response times.

Unfortunately, it was not saved when I checked back on gh.
i’m happy to wait a bit to hear other experiences.
In the meantime, I’m looking into gitlab.

Thank you!

Hi Noa,
Worth to see also: kookma/TW5-GitHub-Saver: Direct saving Tiddlywiki 5.1.20+ to GitHub Pages using the new Tiddlywiki Github Saver Mechanism

See the FAQ section!

Is it all text or do you have lots of images making up that size?
If it’s images you could host them in a different folder on git and then point to them with [img[https:/link to git site]].

ah ha! I think I’ve got it working! On GH, the main directory was still called “master” for some reason so I just manually renamed it “main” and now my file is saving. So the problem did seem to be the “main”/“master” and not the large file size.

Thank you everyone! It’s so nice to be part of this community where this many people want to help so quickly after I post!