Default download saver not working in Chrome 119.0.6045.212

Has anyone else experienced issues using the default download saver with the latest version of Google Chrome? Whenever I try to save changes, it says that it “blocked a dangerous file”.


1 Like

I don’t have any problem with my Chrome (Version 120.0.6099.110 (Official Build) (64-bit)) on Windows 11 (21H2) it certainly sounds like your malware defence is clicking in.

  • Have you another browser try that to determine if it is possibly the computer or if you have any browser safety plugins.

Unfortunately I’m using a Chromebook lol. I could technically install another browser, but it’s not ideal.

Edit: No safety plugins either.

It may prove necessary in the long run to determine if the browser has a problem with your tiddlywiki.

I have a button I use for emergency download with changes when the automatic saver gets in the way, try this;

  • it produces a download button in the page controls.

download-wiki-with-changes.json (1.7 KB) but I expect you to get the same problem.

Just a guess.

Can you check your browser security settings → Security & Privacy → Safe Browsing – Is it set to “Enhanced Protection” or “Standard” ?

I’m having trouble getting it to load over my LAN now (it’s hosted on my phone with RCX), but I will try the download button you provided when I can. Thank you for that.

I was trying to transfer the file from my phone to my Chromebook to upgrade to the latest version. It’s tricky because Chrome OS will only receive the link to my file if I share it from Chrome on Android, and it seems that uploading the HTML file to Google drive now saves it as TXT instead of an HTML file. My workaround was to serve it over LAN from my phone, disconnect RCX, and then click the download saver to download it.

Just a guess.
Can you check your browser security settings → Security & Privacy → Safe Browsing – Is it set to “Enhanced Protection” or “Standard” ?

@pmario - Thank you for the suggestion. Mine is set to “Standard”. I think it is either an issue specific to my wiki or with trying to use the download saver on a file that was served over LAN. I tried downloading an “empty.html” wiki and the download saver worked.

Sorry for the delay in getting back to this. I want to provide an update in case it helps anyone else with the same issue.

@TW_Tones , the download button you provided produced the same issue, as you suspected.

I installed Firefox via Linux for my Chromebook, upgraded from 5.3.1 to 5.3.3 on TiddlyWiki Upgrader — upgrade your files to the latest version, and downloaded the upgraded file. Now when I open the upgraded wiki with Chrome on my Chromebook and press the download button, I do not get the “blocked a dangerous file” message.

Let me know if you have any questions,
Thanks again for your hlep!

@Tiddlybob, you might want to try the Native Saver plugin in your TiddlyWikis in your Chromebook with Chrome.

Thank you, @Alfonso ! I have seen that before, but I’m not sure that it would benefit my specific use-case because I need to keep the file synced across devices. The only time that I need a local copy on my Chromebook is whenever I do upgrades.

The easiest way I have found to keep my wiki synced between my phone and my Chromebook is with WebDAV. Essentially I serve the file via the RCX app on my phone, and I can serve it to the whole local network if I want to use it on my Chromebook.

I just wanted to follow-up with a solution that I found for this. I ran into the issue again today and I found out that in Chrome you can click on the icon before the URL in the address bar (it will say “Not secure” if you are serving over http) > Site Settings > Insecure content: allow. This will allow Chrome to download the wiki.