Getting Fission File Upload Working

Hey @saqimtiaz : AWESOME demo -which made me so eager to try, i have set up a 5.2pre instance of TW in my Fission account, and installed both the FileUploads plugin and the Fission uploader, BUT…

Tho the install seemed to go w/o a hitch, and i was able to drag & drop the image as per your demo, when i looked at the image tiddler, it appears to be stored internally, as there is no canonical URL displayed as in your demo. Hm…

So i looked into Control Panel : Plugins to see if the Fission uploader is there… And it’s not, and neither is the FileUploads plugin. Hm -did i forget to Save after import? Nope: i just reran the import process, made a point of saving… But still: no plugins -just the Core.

Can you think of any reason why this failure to import might be happening?


Hmm. This sounds like an issue with saving on Fission. There were some problems with the service during the demo yesterday but it was working well already late night and again this morning.

I just created a new wiki and installed the plugins with no issues. One thing you can try is at log out of Fission. Reload and authorize it again.

Then I recommend just trying to edit a tiddler and saving and reloading to check if the edit is there. If not, try waiting a couple of minutes and reloading again in case there is some sort of lag on the Fission servers at the moment.

Yep I had the same issue when I was moving a little quickly. The problem is at Fission, not you :slight_smile:

Basically, drag in the File Upload and the Fission Upload plugins, and don’t reload right away. Make some other tiddlers, hit the save button manually, wait a bit until things are saved, and then you can do a hard refresh and the plugins should be there.

What we need to do to “fix” this is make the connection between TW and Fission a bit more robust. Jeremy is doing some experiments with service workers around this.

Indeed -it looks like it’s saving my edits, but then when i refresh they are gone, so…

So i logged-out… And now when i push the “Authorise” button, nothing happens. But i had my volumes at open and accessible in another tab, which said i was logged in as “walt”… But then it also has a “sign-in” link, which i clicked, it asked if i wanted to grant access to my private files, public files and fissiondrive apps folder, so i clicked yes… Then server goes off into la-la land, “checking existence of directories and files” indefinitely…

SO: i’m locked-out at this point, it seems. Will try what i can at this end (reboot browser, wait awhile, try again, etc.) but meanwhile if anyone reading this can intervene, i’d be much obliged!


Hi @ludwa6 – happy to help out. I want to make sure you’ve got a recovery key all set. Head to and run the “Create Recovery Kit” process.

Also feel free to email and we’ll help get you sorted.

I had similar issues after the demo. Logging out and reauthorizing took some trial and error.

The good thing is that once I did reauthorize, all my files were there including the ones uploaded during the demo.

thanks @boris… But, tho says i’m logged in as walt, that dashboard link you sent fwds me on to which is saying “failed to upload data root” -so i can’t access the recovery key process. Do i need one, since i’m logged into my apps?

@ludwa6 … Are you sure your images are >100kByte. In the demo Saq did there was a limit in the filter set to images >100k that are added with a _cannonical_uri … Smaller imges have been directly imported.

Perhaps try authorizing another device if you haven’t already, like your phone.

1 Like

Good point, @pmario -in fact i’d forgotten that fact, thanks for the reminder!- but in this case (just by dumb luck), the image i used through these failed tests weighs in at 209 kb. /walt

Seems worth a try @saqimtiaz -so i did, using Chrome on my iPhone: went to, gave it my username “walt” on request, it returned a screen w/ a 6-digit numeric auth code, asking “Do these numbers match the one shown on your other device?”…

Yet, in Chrome on my desktop -which does say i’m logged in as “walt”- there is no corresponding code, no prompt to approve the other device, nor any prompt whatsoever. The software has nothing to say, apparently… :frowning_face:

Hey @ludwa6 if the numbers show on your phone … it means that you are on the Auth screen & logged in on some browser tab or device.

We verified earlier over chat that you are logged in on Chrome and you can launch your wikis in edit mode from

But it appears to not be saving for you.

As I mentioned, I’ll send you some step by step which will mostly be about closing all browsers and tabs and verifying that regular tiddlers can be saved, and then we can see about getting the plugin installed and saved too.

I’m sorry this has been tricky.

Interesting: when was first launched, i did test on various platforms, and it was all sweetness and light (tho i have no clue how that magic works!)… But it has been some months since i did anything w/ Fission, so… /w

We verified earlier over chat that you are logged in on Chrome and you can launch your wikis in edit mode from

But it appears to not be saving for you.

As I mentioned, I’ll send you some step by step which will mostly be about closing all browsers and tabs and verifying that regular tiddlers can be saved, and then we can see about getting the plugin installed and saved too.

All good to hear, @boris ; i look forward to the email. /w

I’m sorry this has been tricky.

Yeah, man! So here i am, expecting to hook my single-file wiki up to great InterPlanetary FileSystem in the sky, with drag&drop cloud storage of all my images & files at user-defined canonical URI’s for free… So what is all this b’5hit w/ the auth codes, anyway? :laughing:

Seriously: you TW-on-Fission devs are building some earth-shaking stuff here, and i just count myself lucky to be tagging along for the ride. Once this stuff “just works” for the least tech-savvy among us (tho i’m not quite least in this regard, i count this as my tribe), it’s going to be amaaaazing!


Something went awry with the update yesterday. I had similar issues with saving and also had to re-authorize with some hit and miss to get things working. Before that I have never had a problem with Fission.

I just tried to use a new browser and authenticate it and had the same problem:

  • I get the screen asking for my username
  • I get the screen asking me to open that page on a logged in device.
  • Now when I open that URL on in the logged in browser, it flashes the numbers for a second and redirects to without giving me a chance to click approve.
    • This means the new browser never gets authenticated.

I tried 2 more times from scratch in the new browser and on the 3rd attempt it worked, where I could click approve in the already logged in device.

Hi @walt – I realized what went wrong with file uploads from setting up a new one this evening:

We didn’t configure the file uploads plugin, and hence it was using the “dummy” uploader, which makes a myusername path. So the file uploads plugin was definitely there for you.

That still doesn’t explain why the prereleasetest.html isn’t showing up on your files here

I’m going to ask you to do one more thing, which is to create a new user from scratch on Fission.

Use your “other” Google Profile (which is basically another browser), and go to and create a walt2 or similar account.

Then go to and create a new wiki. I’m at a bit of a loss because I’ve created multiple new accounts myself for testing, so best I can tell the gremlins have gotten into your walt account (this will certainly be our fault in coding something messy in an upgrade).

If a new user doesn’t work for you, then it’s something else with your local environment.

Again, thanks for your patience in testing together.

Done, and done: user “walt2” now exists, and has created a new TWOF wiki called “testprerelease.html” -in “public” folder, using 5.1.24-prerelease edition (option at bottom of the wizard’s picklist).

Subsequent improvements made, to get this File Uploads business working:

  1. Install Saq’s Plugin Library (SQPL): whereupon i discovered that this Library does not include the File Uploads plugin (yet! but it’s ok, i wanted the Streams set anyway :slight_smile:
  2. Go to the installation page for the File Uploads plugin, and install both the File Uploads plugin, and the Fission Uploader module.
  3. Save -WAIT (takes some time)- and refresh, to confirm these installations have all landed. CHECK.
  4. Go to config panel on the File Uploads plugin, and ensure that the configs are all correct, i.e.
  • “File Uploader” set to “fission” (had to change pulldown menu from “dummy,” the default)
  • “Type of canonical URI” set to “public” -CHECK
  • “Upload folder path relative to root of public folder” set to “files” -CHECK
    Note: the confirmation msg below that config widget now says " URL of configured upload folder:

Ah, one other thing:

  1. Go to the “File Uploads: Fission” plugin to ensure that “Type of canonical_URI” and “Upload folder path relative to root of public folder” is the same as on the “File Uploads” plugin above -CHECK.

So now: does it work as promised, per Saq’s amazing demo? Alas, it does not; the “TestImageUpload” tiddler i created, containing an image i drag&dropped in place (148kb, so it’s over the 100kb minimum) appears to have stored the image in the .html file itself, instead of creating a new image tiddler using canonical_URI.

Also: Tho i had the impression from what @saqimtiaz said in video that i would need to create the “files” subfolder myself, since you said @boris that the app would create that folder automatically, i went to my folder to see if this did in fact happen… But as of now (~90 minutes since creating the test), i’m still seeing a blank screen with that “Just a moment, loading the filesystem” spinner spinning, so i guess i’ve waited about long enough for process to complete! :slight_smile:

Ok the wiki is there for walt2:

And the files folder is created and it has an image in it.

So it looks to have worked.

I got bitten by this as well when testing the latest changes. I believe it makes sense to not have the default uploader set to “dummy” and show a message to the user if no uploader is configured.

Yes indeed Boris: i don’t know why it didn’t create a separate image tiddler w/ canonical_URI when i first tried it & file this report… But, tho i have since not made any changes and now there is a separate image tiddler w/ the canonical_URI pointing to storage inside “…/files” subfolder, it’s now working as it should- so i’m a happy camper. :smiley:

PS: Unfortunately, the Streams plugin did not work; it did show up in the UI, but when i try to create a node, it throws a big red box w/ following error message, so i deleted the plugin from this instance:

Internal JavaScript Error

Well, this is embarrassing. It is recommended that you restart TiddlyWiki by refreshing your browser

Uncaught TypeError: Cannot read properties of null (reading 'matches')

I believe that TWoF doesn’t use the latest pre-release of TW 5.2.0 and that is responsible for the Streams related issues.